通达信k线为红色,请老师编写一个通达信公式k线在线上为红色,线下为绿色

内容导航:
  • 请老师编写一个通达信公式k线在线上为红色,线下为绿色
  • 通达信 如何改变k线颜色
  • 通达信中红色实体K线代表什么?
  • 求高手将通达信此指标K线改成正常红绿色K线
  • 通达信选股公式,表示均线向上
  • 求通达信均线顺畅选股公式
  • Q1:请老师编写一个通达信公式k线在线上为红色,线下为绿色

    EMA10:EMA(C,10);
    VA:=EMA10>REF(EMA10,1);
    VB:=EMA10<REF(EMA10,1);
    STICKLINE(VA,O,C,2.5,0)COLORRED;
    STICKLINE(VA,H,L,0,0)COLORRED;
    STICKLINE(VB,O,C,2.5,0)COLORGREEN;
    STICKLINE(VB,H,L,0,0)COLORGREEN;

    Q2:通达信 如何改变k线颜色

    由于均线是系统设置的指标,虽然你可以修改颜色,但通达信会提示在下一次运行时将恢复系统的设置。所以你只能自己编写一个均线的公式来用。方法也很简单,只要单击公式管理器按钮调出公式管理器,新建一个公式,单击“引入指标公式”,选择名称为 MA 的均线,就自动将所有均线的公式复制出来。将公式名称改一下,加入公式描述,在每条公式加入你希望的颜色,例如红色为 COLORRED,确定就可以了。最后在主图上选择刚才建立的公式,就能运用上。这个指标,你可以随时修改颜色。

    Q3:通达信中红色实体K线代表什么?

    换一个股票行情软件吧

    Q4:求高手将通达信此指标K线改成正常红绿色K线

    JRH:=HHV(C,2);
    JRL:=LLV(C,2);
    MA3:=MA(CLOSE,3);
    YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
    VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
    VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
    VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);
    VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
    红色持股:VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;
    离场:=IF(红色持股,JRL,DRAWNULL);
    明离场价:=离场,COLORFF99FF,NODRAW;
    今离场价:REF(离场,1)COLOR0000FF,NODRAW;
    青色观望:VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,COLORFFFF00,NODRAW;
    进:=IF(青色观望,JRH,DRAWNULL);
    明进场价:=进,COLOR33AACC,NODRAW;
    今进场价:REF(明进场价,1),COLORFF0000,NODRAW;
    短买:VAR19,COLOR33AACC,NODRAW;
    品红离场:VAR1A,COLORFF99FF,NODRAW;
    急速超跌:(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORFFFFFF,NODRAW;
    上市日期年:REF(YEAR,BARSCOUNT(CLOSE)-1),NODRAW,COLOR0000FF;
    月:REF(MONTH,BARSCOUNT(CLOSE)-1),NODRAW,COLORFF00FF;
    日:REF(DAY,BARSCOUNT(CLOSE)-1),NODRAW,COLOR00FFFF;
    辰星线:(20*YTSL+19*REF(YTSL,1)+18*REF(YTSL,2)+17*REF(YTSL,3)+16*REF(YTSL,4)+15*REF(YTSL,5)+14*REF(YTSL,6)+13*REF(YTSL,7)+12*REF(YTSL,8)+11*REF(YTSL,9)+10*REF(YTSL,10)+9*REF(YTSL,11)+8*REF(YTSL,12)+7*REF(YTSL,13)+6*REF(YTSL,14)+5*REF(YTSL,15)+4*REF(YTSL,16)+3*REF(YTSL,17)+2*REF(YTSL,18)+REF(YTSL,20))/211,COLOR0000FF;
    牵牛线:MA(CLOSE,26),COLORFF00FF;
    等待:=IF(MA3>辰星线,辰星线,MA3);
    IF(等待>REF(等待,1),等待,DRAWNULL),LINETHICK2,COLOR00FFFF;
    IF(辰星线>REF(辰星线,1),辰星线,DRAWNULL),LINETHICK2,COLOR0000FF;
    IF(辰星线<REF(辰星线,1),辰星线,DRAWNULL),COLOR00FF00;
    IF(牵牛线>REF(牵牛线,1),牵牛线,DRAWNULL),LINETHICK1,COLORFF00FF;
    IF(牵牛线<REF(牵牛线,1),牵牛线,DRAWNULL),COLOR669933;
    DRAWTEXT(短买,REF(CLOSE,1),'←短买'),COLOR33FFCC;
    DRAWTEXT(品红离场,REF(CLOSE,1)+0.1,'←离场'),COLORFF99FF;

    Q5:通达信选股公式,表示均线向上

    count(ma(c,N)>=ref(ma(c,n),1),M)=M;{N为均线周线,选5代表5日均线,M为均线形态周期,选10表示连续10日走平或向上,如果只要向上不要走平的话,就把ref(ma......前的等号删去}

    Q6:求通达信均线顺畅选股公式

    EXP CYC

    上一篇:上一篇:丘少梅炒股是真的吗
    下一篇:下一篇:亚马逊一股多少
    • 评论列表

    发表评论: